Reparar el AUR en Antergos: Package-query Instrucción Ilegal

No suelo utilizar el AUR a no ser que sea estrictamente necesario para instalar algún programa en concreto. Pero hoy lo he ido a utilizar en Antergos para instalarme y probar el cliente de Twitter Corebird.

Y nada, no había manera, no encontraba ningún paquete. Al mismo tiempo, escupía la siguiente línea de error

/usr/lib/yaourt/util.sh: línea 190: 21133 Instrucción ilegal     (`core' generado) package-query "${PKGQUERY_C_ARG[@]}" "$@"
 error: destino no encontrado: corebird

Lo que parecía indicar que realmente el problema lo generaba el programa package-query. Afortunadamente, no he sido el único usuario que se ha topado con este error, y hay información de cómo solucionarlo en Reddit, y dicha solución es bastante sencilla: se basa en desinstalar ese paquete y compilarlo a mano. Siguiendo los comandos uno a uno es imposible perderse:

#Primero desinstalamos el paquete
sudo pacman -Rdd package-query
#Descargamos el archivo fuente
wget https://aur.archlinux.org/cgit/aur.git/snapshot/package-query.tar.gz
#Extraemos la carpeta
tar -xzvf package-query.tar.gz
cd package-query
#Dejamos la magia de la compilación a makepkg
makepkg -sri

Fuente | Reddit

0 0

Pimagizer, por fin, para Arch Linux

Tuvo hace algunos meses una escasa presencia en el AUR, el repositorio de Usuarios de Arch, pero debido a cambios que hicieron y a que no tuve tiempo en su momento, lo dejé pasar un poco. Ahora ha renacido y está disponible la aplicación Pimagizer lista para instalar en Arch y derivados con un sólo comando:

sudo yaourt -S pimagizer

Lo he podido probar sólo en mi ordenador. Si encontráis errores, no dudéis en reportarlos.

Y ya aprovecho y si no la conocéis, pues la doy un poco de bombo

Captura de Pimagizer en AntergosPimagizer nació para hacer la vida fácil a todos. Nació para muchas personas, que como yo trabaja con la web y necesita subir imágenes cambiando el tamaño de las fotos para no sobrecargar con muchos datos el tráfico. Porque muchas veces si se ve bien, no es necesario subir una imagen de 5Mb cuando los usuarios pueden ver mermado su rendimiento.

Nació prácticamente con Gnome 3 y ha ido evolucionando con él. Soy consciente de que necesita muchas mejoras, pero el código está en launchpad, y no es nada complicado colaborar. Os animo, aunque sea, a traducirla 😉

Saludos!

 

3 1