Reparar el AUR en Antergos: Package-query Instrucción Ilegal

No suelo utilizar el AUR a no ser que sea estrictamente necesario para instalar algún programa en concreto. Pero hoy lo he ido a utilizar en Antergos para instalarme y probar el cliente de Twitter Corebird.

Y nada, no había manera, no encontraba ningún paquete. Al mismo tiempo, escupía la siguiente línea de error

/usr/lib/yaourt/util.sh: línea 190: 21133 Instrucción ilegal     (`core' generado) package-query "${PKGQUERY_C_ARG[@]}" "$@"
 error: destino no encontrado: corebird

Lo que parecía indicar que realmente el problema lo generaba el programa package-query. Afortunadamente, no he sido el único usuario que se ha topado con este error, y hay información de cómo solucionarlo en Reddit, y dicha solución es bastante sencilla: se basa en desinstalar ese paquete y compilarlo a mano. Siguiendo los comandos uno a uno es imposible perderse:

#Primero desinstalamos el paquete
sudo pacman -Rdd package-query
#Descargamos el archivo fuente
wget https://aur.archlinux.org/cgit/aur.git/snapshot/package-query.tar.gz
#Extraemos la carpeta
tar -xzvf package-query.tar.gz
cd package-query
#Dejamos la magia de la compilación a makepkg
makepkg -sri

Fuente | Reddit

0 0

Firefox Developer Edition: Instalación en Manjaro y Arch

Mozilla ha reinventado la rama Aurora de Firefox, dotándola de un IDE integrado en el navegador y otras herramientas ya existentes, orientándolo tanto para el desarrollo en la web como para crear aplicaciones para Firefox OS.

firefox develEsta nueva edición para desarrolladores no trae un conjunto especialmente grande de cambios, pero sin duda las herramientas que vienen por defecto lo hacen bastante atractivo para aquellos que trabajan en el desarrollo web. Algunas páginas también se han hecho eco de la noticia y muestran más a fondo estas novedades.

Si lo que queremos es instalar Firefox Developer Edition en nuestro ordenador, y tenemos instalado Manjaro o Archlinux (o algún derivado) podemos obtener los paquetes del AUR con la compilación de Firefox Aurora. También hay paquetes en otros idiomas, pero muchos de ellos no han sido actualizados a la última revisión.

yaourt -S firefox-aurora

Ala, ¡A pelearse con Javascript se ha dicho!

Saludos 😉

0 0

Actualizar también los paquetes del AUR

Podría parecer trivial, pero no. Si lo que quieres es actualizar los paquetes que instalaste con Yaourt desde el repositorio de usuarios de arch (AUR), lo que necesitas es añadir el flag “–aur” al comando similar al de pacman:

Vamos, que en definitiva un

yaourt -Syu –aur

pone a yaourt a buscar los paquetes desactualizados que instalaste desde el AUR

Saludos 😉

0 0