Manjaro: actualizaciones con problemas

No es raro que muchas veces al intentar actualizar Manjaro (que proviene de Arch) me de problemas del tipo ¿Desea desinstalar mesa-drivers? ¿xorg? ¿systemd? Obviamente este tipo de paquetes hay que tener cuidado de no quitarlos, son bastante esenciales para nuestro sistema.

Así que si da problemas, ejecutamos lo siguiente, que consiste en que actualiza los paquetes nuevos y otro tipo de información.

$ sudo pacman -Syyu

o incluso también

$ sudo pacman -Syyuu

Error en Manjaro: pamac local es más nuevo que extra

No sé a qué es debido, pero el caso es que al llamar a Pacman para instalar o actualizar, me salta este error. Llevaba ya un tiempo con él, pero hoy, ha intentado actualizar, pero se ha negado.

Error pamac
Error al llamar a Pacman

La solución es sencilla, pasa por hacer un downgrade del paquete, que se consigue con la opción -Suu en pacman. Pero claro, se te tiene que ocurrir. Yo la encontré en los foros de Manjaro en inglés.

sudo pacman -Suu pamac

Y con esto se solucionan nuestros problemas 🙂